[opencms-dev] Compile error jasper upgrading from 7.5.4 to opencms 8.0.4 (solved)

Hein van der Kallen hvanderkallen at xs4all.nl
Sun Apr 22 20:40:34 CEST 2012

Upgraded opencms 7.5.4. + mysql  + tomcat 5.0  running on a recent JAVA_HOME. 
to opencms 8.0.4 using the opencms upgrade. 

Got error directly after the database update: ( browser in ...update/step_0_dbsettings.jsp)
In logging:




17 Apr 2012 11:49:32,244 ERROR [pache.jasper.compiler.Compiler: 432] Error compiling file: ....org/apache/jsp/update/step_005f0_005fdbsettings_jsp.java 

    [javac] Compiling 1 source file


... org/apache/jsp/update/step_005f0_005fdbsettings_jsp.java:154: generics are not supported in -source 1.3

(use -source 5 or higher to enable generics)

Solved it using http://firstclassthoughts.co.uk/java/tomcat_5_eclipse_source_1.5.html

which suggests to insert 









I inserted it in the jasper part of web.xml of opencms, cleared jsp-cache and 

restarted upgrade. Solved.

I regret that older documentation like in /alkacon-documentation/ was not updated. 

And I spent a lot of extra time getting the new opencms 8 demo's loaded from the full version.

But succeeded.


(Hein van der Kallen)


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://webmail.opencms.org/pipermail/opencms-dev/attachments/20120422/d05ef89b/attachment.htm>

More information about the opencms-dev mailing list