[opencms-dev] Cannot create project

Ulrich Rueth ulrich.rueth at gmx.de
Sun Mar 24 19:43:24 CET 2002

as I am completely new to OpenCMS and there is little documentation, so
I have a few questions that might be easy for you to answer.

I have set up MySQL, Tomcat 4 and OpenCMS according to the installation
instructions (under Linux with Mozilla 0.9.9 which should be no
difference to Netscape 6.2). I ran the setup wizard and everything
seemed to run fine (except that at the end when trying to import the
workplace, it took ages but no more java process was running so I
regarded it as finished). I logged in as admin and created a new user.

Problem: I cannot create a new project, the "New Project" icon is grayed
out and inactive. I can do so in the Administration view "New Project",
but I have the feeling that the project is not created. Though I
specified my new user as Projectmanager, I cannot see the project when I
log in as this user (in fact the project does not even appear in the
Administrator's project overview directly after having created it).

My concern is that I set up something wrong in MySQL. In the opencms.log
the following lines appear:

[22.03.2002 00:18:38] <opencms_critical> [CmsXmlWpTemplateFile]
Requested datablock  "time" not found!
[22.03.2002 00:18:40] <opencms_critical>
[com.opencms.file.mySql.CmsDbAccess] /default/vfstest

(and in fact, I tried to create a "test" project with a "test" folder).

As I am new to MySQL, this might be the problem. Any idea?

Furthermore, in the last point of the installation instructions I cannot
find the place in the opencms.properties file ment by

"Don't forget to add the new user and password to all connect strings of
the database in your opencms.properties file."

Where are those "connect strings"???


More information about the opencms-dev mailing list