[opencms-dev] Problems with the write support in webdav

Christian Steinert christian_steinert at web.de
Tue Feb 24 22:56:13 CET 2009

Alberto Abián ha scritto:
> Hi all,
> Thank you for the answer in this short time. I mount the webdav partition
> with the root user and I use the opencms user "Admin" when the username is
> requested.
> When the partition is mounted, I can obtain the following information:
> root at blablabla:/# mount
> on /media/webdav type davfs
> (rw,nosuid,noexec,nodev,_netdev)
I had tried davfs a while ago and gave up using it after a short while.
I did not try to create any files but I tried changing lots of existing 
files (mass search and replace). With that, I had the problem, that 
davfs piled up the changes that I made in its local cache but did not 
alway properly replicate the changes over to the server (sometimes, the 
file changes did not even end up in opencms, even after I had asked 
davfs to unmount again (which should normally force a sync of all changes).

This was about the point when I gave up, blaming davfs for the overall 

The problem with creating files that is mentioned in the other post 
sounds like an opencms bug though and might be worth a bug report. As 
noted before, I only tried changing files. In that case, it seemed as if 
webdav locks were translated directly into opencms lock states.For 
existing resources this makes a lot of sense and it might also explain 
why the implementation has trouble with locking file names for files 
that are only about to be created.

In short: you might end up having to write a bug report about the file 
creation problem at least.

Best Regards

More information about the opencms-dev mailing list