[opencms-dev] Error #404 at every URL

Christian Steinert christian_steinert at web.de
Tue Feb 3 15:15:44 CET 2009

If you install the cms as root application without changing the web.xml 
then opencms should be at
Don't forget that the main servlet within the opencms web application 
adds another opencms prefix.

and the login page should be at

> Hi everybody:
> Does anybody know why I can't see any OpenCms page at all (nor the
> workplace)?  All of them shows the "A system error reading a resource
> occurred!" #404 server error message instead of the actual page.
> I suppose it has to do something with some RFS folder permission (I
> was suspecting about the "export" folder...), but I can't get it. I've
> compared my installation with other I have here and I can't find much
> differences. The new "export" folder has many less files than the
> working installation, but the files used for the actual error page
> (such as the warning symbol) are created there.
> My new installation runs on Debian 4.0, with Tomcat 5.5 and MySQL
> 5.0.32, all installed from official Debian repositories. I've tried
> importing the old database and using the setup wizard from zero, with
> the same results. It's installed as the "ROOT" web application, and
> I'm consciously using the security manager (although I've tried
> deactivating it without success), for which I've given the following
> permissions in "/etc/tomcat5.5/policy.d/50user.policy":
>     grant codeBase "file:/usr/share/tomcat5.5/bin/tomcat-juli.jar" {
>       permission java.io.FilePermission
> "/var/lib/tomcat5.5/webapps/ROOT/WEB-INF/classes/logging.properties",
> "read";
>     };
>     grant codeBase "file:/var/lib/tomcat5.5/webapps/ROOT/-" {
>       permission java.security.AllPermission;
>     };
> What's happening, what I'm missing? Do you have a similar installation
> and can you show me the contents of your "50user.policy" file?
> Thank you in advance.

More information about the opencms-dev mailing list