[opencms-dev] locale change in custom xmlcontent

Sandrine Prousteau s.prousteau at eurelis.com
Fri Jan 16 12:00:07 CET 2009


Yes when It's the way I must modify my files : opening Editcontrolcode, and changing the value "en" to "fr". I only have one locale initialized. Is there a way to add a locale in an xmlcontent by the administration buttons?

 

This problem appears when the xmlcontents are created first by default in locale EN, and next I must correct locale by adding locale FR in config files and restrict my folder content locales propositions to only this locale FR (by add "fr" in property of the folder). And I don't want to lost all data...

 

________________________________

De : opencms-dev-bounces at opencms.org [mailto:opencms-dev-bounces at opencms.org] De la part de Carl Alex Friis Nielsen
Envoyé : vendredi 16 janvier 2009 11:59
À : The OpenCms mailing list
Objet : Re: [opencms-dev] locale change in custom xmlcontent

 

Does the content really only have one locale, or is the second locale present, but empty ?

 

If only the "en" locale is present, the cms should default to that content, despite the "fr" locale in the locale property

(of the resource or inherited). If you do have an empty "fr" content in the resource, that will be displayed.

 

Not sure what you want the locales-available for (depends on your template of course) - we don't use that.

 

If your template is coded not to do this it obviously won't happen.

 

If you use "edit controlcode" on the resource you can examine the xml as text and easily determine if other locales

Are present.

 

Cheers,

 

Carl

 

 

Fra: opencms-dev-bounces at opencms.org [mailto:opencms-dev-bounces at opencms.org] På vegne af Sandrine Prousteau
Sendt: 15. januar 2009 14:27
Til: The OpenCms mailing list
Emne: [opencms-dev] locale change in custom xmlcontent

 

Hi, a trivial question..

I've got some custom xmlcontent file in a folder, and they have been edited in a locale (ex : "en"). Then I add in properties 'locale-available' and 'locale' value "fr" for example to the parent folder. So the values of my xmlcontent are not write anymore, I have to change it to "fr". Is there a trivial way to change in one click all data under a folder, instead of having to change it in each file in the xml code??

Locales "fr" and "en" are already configured in WEB-INF config files.

Thanks.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opencms.org/pipermail/opencms-dev/attachments/20090116/8c610dc9/attachment.html>


More information about the opencms-dev mailing list