[opencms-dev] Wrong dialog handler: org.opencms.frontend.templateone.CmsPropertyTemplateOne

David Trattnig david.trattnig at gmail.com
Tue Nov 27 11:16:53 CET 2007


I see, thank you, I didn't notice yet. But I'm still wondering why it's
different at the CVS version? There you don't have the Template1 version.

Rgds
David


On Nov 27, 2007 9:54 AM, Michael Moossen <m.moossen at alkacon.com> wrote:

> Hi!
>
> if you check older releases you will realize that always the template
> one property dialog has been configured by default, that has additional
> input fields for template one specific properties.
>
> if you want to get completely rid of the template one module you will
> have to change this to the generic CmsPropertyAdvanced
>
> Kind regards,
> Michael
>
> -------------------
>
> Alkacon Software GmbH - The OpenCms Experts
> Michael Moossen
>
> http://www.alkacon.com
> http://www.opencms.org
>
>
>
> David Trattnig wrote:
> >
> >     Hi,
> >
> >     I've found a dialog handler in the default workplace configuration
> >     of OpenCms 7.0.3 which is part of the Template One Addon:
> >
> >         <dialoghandlers>
> >           <!-- Dialog handlers are configurable for the workplace
> >     dialogs: delete, lock/unlock and file properties.
> >                  If OpenCms does not start because a customized dialog
> >     handler class is not found, use the following default dialog handler
> >     classes:
> >                  Delete dialog: org.opencms.workplace.commons.CmsDelete
> >                  Lock dialog: org.opencms.workplace.commons.CmsLock
> >                  Property dialog:
> >     org.opencms.workplace.commons.CmsPropertyAdvanced
> >           //-->
> >           <dialoghandler class="org.opencms.workplace.commons.CmsDelete"/>
> >           <dialoghandler class="org.opencms.workplace.commons.CmsLock"/>
> >           <dialoghandler
> >     class="*org.opencms.frontend.templateone.CmsPropertyTemplateOne*"/>
> >         </dialoghandlers>
> >
> >     I reckon this has been mixed up - the orginal handler was
> >     *org.opencms.workplace.commons.CmsPropertyAdvanced
> >     *This just happens in the zipped download-version of OpenCms 7.0.3 -
> >     the CVS version seems to be okay.
> >
> >     Cheers,
> >     David*
> >     *
> >
> >
> >
> >
> > --
> > David Trattnig
> >
> > tel   | +43 650 8855388
> > w1  | www.bearingpoint.com <http://www.bearingpoint.com>
> > w2  | www.bitfusion.org <http://www.bitfusion.org>
> > px   | www.flickr.com/photos/david-trattnig
> > <http://www.flickr.com/photos/david-trattnig>
> >
> >
> > ------------------------------------------------------------------------
> >
> >
> > _______________________________________________
> > This mail is sent to you from the opencms-dev mailing list
> > To change your list options, or to unsubscribe from the list, please
> visit
> > http://lists.opencms.org/mailman/listinfo/opencms-dev
>
> _______________________________________________
> This mail is sent to you from the opencms-dev mailing list
> To change your list options, or to unsubscribe from the list, please visit
> http://lists.opencms.org/mailman/listinfo/opencms-dev
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opencms.org/pipermail/opencms-dev/attachments/20071127/f8fee03e/attachment.html>


More information about the opencms-dev mailing list