[opencms-dev] PDF Publish problem

Keith Davey keith.davey at gmail.com
Wed Dec 14 11:57:29 CET 2005


Hi,

I am having a problem publishing PDFs which I am hoping someone has seen
before.

I can upload the files no problem but once I try to publish them errors get
thrown.

It doesn't seem to be size related and I have tried different names etc.
Some files work fine,
others just won't publish.

I am running OpenCMS 6.0.2 on Jboss 4.0.3 with Postgres 8.1 on Centos Linux.

The error is:

*Validating links ...*
*... finished validating links*
*Publishing resources ...*
*Publishing files ...*
( 1 / 1 ) Publishing file /mysite/docs/we_brochure.pdf ... *Error publishing
file "/sites/default/mysite/docs/we_brochure.pdf". *
*Exception org.opencms.file.CmsVfsResourceNotFoundException: Unable to read
file with structure ID "6d2e6fea-6c0f-11da-b1e7-0015600ce03a".**
at org.opencms.db.generic.CmsVfsDriver.readFile(CmsVfsDriver.java:1053)
at org.opencms.db.generic.CmsProjectDriver.publishFileContent(
CmsProjectDriver.java:1244)
at org.opencms.db.generic.CmsProjectDriver.publishFile(CmsProjectDriver.java
:1106)
at org.opencms.db.generic.CmsProjectDriver.publishProject(
CmsProjectDriver.java:1626)
at org.opencms.db.CmsDriverManager.publishProject(CmsDriverManager.java
:4418)
at org.opencms.db.CmsSecurityManager.publishProject(CmsSecurityManager.java
:2889)
at org.opencms.file.CmsObject.publishProject(CmsObject.java:1942)
at org.opencms.workplace.threads.CmsPublishThread.run(CmsPublishThread.java
:122)
*Statistics: published files: 1, published folders: 0, deleted folders: 0,
duration: 00:00:00
*Exception org.opencms.file.CmsVfsResourceNotFoundException: Unable to read
file with structure ID "6d2e6fea-6c0f-11da-b1e7-0015600ce03a".**
at org.opencms.db.generic.CmsVfsDriver.readFile(CmsVfsDriver.java:1053)
at org.opencms.db.generic.CmsProjectDriver.publishFileContent(
CmsProjectDriver.java:1244)
at org.opencms.db.generic.CmsProjectDriver.publishFile(CmsProjectDriver.java
:1106)
at org.opencms.db.generic.CmsProjectDriver.publishProject(
CmsProjectDriver.java:1626)
at org.opencms.db.CmsDriverManager.publishProject(CmsDriverManager.java
:4418)
at org.opencms.db.CmsSecurityManager.publishProject(CmsSecurityManager.java
:2889)
at org.opencms.file.CmsObject.publishProject(CmsObject.java:1942)
at org.opencms.workplace.threads.CmsPublishThread.run(CmsPublishThread.java
:122)*
Has anyone had this problem before.

Thanks,

Keith
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opencms.org/pipermail/opencms-dev/attachments/20051214/5274cd1c/attachment.html>


More information about the opencms-dev mailing list