[opencms-dev] creating new user, exception at first login

Yuval Zukerman YZukerman at molecular.com
Fri Nov 18 22:58:19 CET 2005


We experienced the same situation. A user could not log into the system
until you go into the preferences screen and set up the default project. Got
the same unless that setting was made.
 
- yz

Message: 8

Date: Thu, 17 Nov 2005 15:21:43 -0500

From: Marcus Popetz <marcus at roundpeg.com>

Subject: [opencms-dev] creating new user, exception at first login

To: opencms-dev at opencms.org

Message-ID: <6.1.0.6.0.20051117151642.03a2ed28 at mail.cpopetz.com>

Content-Type: text/plain; charset="us-ascii"; format=flowed

I need some help tracking this down so I can submit a meaningful bug:

When I create a new user, the first time I log in as them I get the
following exception:

org.opencms.main.CmsRuntimeException: Error reading resource from path "/".

at

org.opencms.workplace.explorer.CmsExplorer.getFileList(CmsExplorer.java:176)

at

org.apache.jsp.WEB_002dINF.jsp.offline.system.workplace.views.explorer.explo
rer_005ffiles_jsp._jspService(org.apache.jsp.WEB_002dINF.jsp.offline.system.
workplace.views.explorer.explorer_005ffiles_jsp:58)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)

 

If I ignore it, and click on the preferences button, and then click "ok" 

(without changing anything) it then works fine.

I assume this means defaults are not set up quite correctly for the user,
but they are loaded correctly into the UI which is why a save with no
changes fix the problem?

Any ideas what info I need to gather (from VFS? from xml?) to submit this as
a bug?

-mp

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opencms.org/pipermail/opencms-dev/attachments/20051118/ec221f1c/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 3036 bytes
Desc: not available
URL: <http://lists.opencms.org/pipermail/opencms-dev/attachments/20051118/ec221f1c/attachment.bin>


More information about the opencms-dev mailing list