[opencms-dev] Forum Module (mvnForum) for OpenCms 6.x availablefordownload

Arash Kaffamanesh arash.kaffamanesh at pomegranate.de
Tue Oct 18 13:57:52 CEST 2005


Hi Jakob,
 
thanks for the feedback. I've tested the module on Windows with a fresh
OpenCms 6.0.2 Installation, without any major issue.
 
The preconditios are:
 
1. Install OpenCms a opencms.war (and not ROOT.war) under webapps.
2. Select opencms as DB-Name during the installation of opencms.
3. control mvncore.xml for the following entries
 
<driver_class_name>com.mysql.jdbc.Driver</driver_class_name>
 
<database_url>jdbc:mysql://localhost/opencms?useUnicode=true&charact
erEncoding=utf-8</database_url>
        <database_user>opencmsuser</database_user>
        <database_password>admin</database_password>
 
use first root as opencmsuser with appropriate password, also:
 
<database_user>root</database_user>
<database_password>whatever-secret-password</database_password>
 
(I guess your problem is here!)
 
4. the mysql-connector-java-3.0.15-ga-bin.jar must be under
webapps\opencms\WEB-INF\lib
at least it works for me, if you are using MySQL 4.1 on windows,
download the latest mysql jdbc driver (I think
mysql-connector-java-3.0.16-ga-bin.jar)
 
5. Touch your module and publish all files.
 
6. restart tomcat
 
If this doesn't help, please provide the follwing infos:
 
Tomcat version
your jdbc driver
trace log (opencms.log and catalina.out)
does your opencms installation work properly?
 
Looking to hear from you.
 
Kind Regards,
Arash

-----Original Message-----
From: opencms-dev-bounces at opencms.org
[mailto:opencms-dev-bounces at opencms.org] On Behalf Of Jakob Lemler
Sent: Dienstag, 18. Oktober 2005 13:34
To: 'The OpenCms mailing list'
Subject: AW: [opencms-dev] Forum Module (mvnForum) for OpenCms 6.x
availablefordownload


hi Arash,
 
first of all thanks for the module, althought it does not work here
until yet. 
But the reason why is  just peanuts (almost for sure ... ;-))
 
Tried to install it with ocms 6.02 according to your description. But it
does not work because the mysql jdbc driver could not be found ... (as
far as I understand the error message further down).
 
In my installation, there is an actual jdbc-driver under
"%catalina_home%\common\lib" (3.1.11) additionally to the version which
comes with opencms in the WEB-INF\lib directory (3.0.15-ga-bin). As far
as I understand the one under the common directory should be found (and
should be usable) by all deployed webapps. Additionally the one in the
opencms tree should be used first... So I do not get what's the reason
why... ;-(
 
How the modul is "looking up" the driver? Is it possible (or perhaps a
must) to use the tomcat connection pool ??? 
If so, what exactly do I have to include in the mvncore.xml file?
 
As you can see, these are the questions of a non programmer ...
Hopefully interesting to otherones too... ;-)
 
regards and tia for your answer!
jakob
 
environment:
- win xp sp1
- mysql 4.1.13
- jdbc driver 3.1.11
- tomcat 5.5.12
- opencms 6.0.2
- jdk 1.5.0
 
Screen-Message:


mvnForum Fatal Error Message : Cannot init system. Reason : Check your
database configuration. Detail : DBUtils: Cannot get connection from
Connection Pool.

stdout.log:
"2005-10-18 12:04:49,278 ERROR [ajp-8019-1] db.DBConnectionManager
(DBConnectionManager.java:356)     - Cannot create a new connection in
DBConnectionPool. URL =
http://capella.chako.de:8080/opencms/mvnforum/?useServerPrepStmts=false
java.sql.SQLException: No suitable driver
 at java.sql.DriverManager.getConnection(Unknown Source)
 at java.sql.DriverManager.getConnection(Unknown Source)"

 
The data in mvncore.xml:
<dboptions>
        <!--
         if USE_DATASOURCE = false, use the default built-in connection
pool
         if USE_DATASOURCE = true,  use the connection pool that Servlet
Container provides
        -->
        <use_datasource>false</use_datasource>
        <!--
         You should NOT change the DATABASE_TYPE below
         By default, DATABASE_TYPE = 0
         NOTE: If your database/driver doesnt support scrollable
resultset
               (such as some version of Interbase/Firebird), set
DATABASE_TYPE = 2
        -->
        <database_type>0</database_type>
        <!--
         Set the below options if you want to use default connection
pool
         This is applied if you set USE_DATASOURCE = false
         MINUTES_BETWEEN_REFRESH is the minutes between built-in
Connection Pool refreshment
               Some time your database server is set connection timeout
too low, such as
               5 minutes, that cause the connection auto disconnected.
In this case you should
               set MINUTES_BETWEEN_REFRESH lower than the server
connection timeout value
         NOTE: These values can be obtained from the header of the
               sql script for your database
         NOTE: For compatible with future release of mvnForum, we highly
               recommend that use config your database/driver to use
unicode utf8 encoding
        -->
        <driver_class_name>com.mysql.jdbc.Driver</driver_class_name>
        <!--
<database_url>jdbc:mysql://localhost/opencms?useUnicode=true&charact
erEncoding=utf-8</database_url> -->
 
<database_url>http://capella.chako.de:8080/opencms/mvnforum/?useServerPr
epStmts=false</database_url>
        <database_user>XXXX</database_user>
        <database_password>XXXXXXXXX</database_password>
        <max_connection>30</max_connection>
        <max_time_to_wait>2000</max_time_to_wait>
        <minutes_between_refresh>15</minutes_between_refresh>
        <!--
         Set the Data source name if you want to use Servlet Container
connection pool
         This is applied if you set USE_DATASOURCE = true
        -->
        <datasource_name/>
    </dboptions>

 
 -----Ursprüngliche Nachricht-----
Von: opencms-dev-bounces at opencms.org
[mailto:opencms-dev-bounces at opencms.org] Im Auftrag von Arash
Kaffamanesh
Gesendet: Dienstag, 18. Oktober 2005 03:52
An: opencms-dev at opencms.org
Betreff: [opencms-dev] Forum Module (mvnForum) for OpenCms 6.x available
fordownload



Hi,
 
as promised last week (and last year ;-)) an easy to use: 
 
OpenCms-mvnForum-Plugin Module
 
is now available for download.
 
Module Name: org.opencms.mvnforum.plugin
Date released: 2005/10/17
Integrator: Arash Kaffamanesh
Version: 0.18
Download Size: 5.7 MB
 
Description:
 
This module has been tested with the latest OpenCms 6.0.2, MySQL 4.x on
Windows 2000 and includes the latest mvnForum RC4,
it comes as it is without any garanty and with respect to terms and
conditions of mvnForum and OpenCms licensing rules (LGPL GNU License).
 
Preconditions:
 
You shall have installed OpenCms 6.x with MySQL 4.x on Tomcat 5.x (Java
1.5 recommended) under webapps/opencms.
 
Further information and download available from:
 
http://www.pomegranate.de/en/OpenSource/OpenCMS/downloads/index.html
 
Please provide feedback. 
 
After sufficient testing it could be uploaded to OpenCms 6 Sandbox, in
the case that any of You could find it useful and OpenCms Experts at
Alkacon would like to do so :-)
 
Kind Regards,
Arash
 ______________________________________
|arash kaffamanesh

|                                                                  

|http://www.pomegranate.de
|global portal & content management solutions
|______________________________________
 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opencms.org/pipermail/opencms-dev/attachments/20051018/7a2ac60f/attachment.html>


More information about the opencms-dev mailing list