[opencms-dev] 6.0.0 on Resin 3.0.14 & OSX

Jalmari Raippalinna jalmari.raippalinna at sulake.com
Tue Oct 18 09:22:31 CEST 2005


I'm trying to install OpenCMS development server on my powerbook  
laptop and noticed following things:

I'm using following configuration:
OSX 10.4.2
Resin 3.0.14 installed to /opt/resin via symbolic link (Also  
10/10/2005 Snapshot available for testing), max heap size changed to  
256M
MySQL 4.1.14 (max_packet_allow=16M)

To opencms WEB-INF/web.xml following changes have been done to make  
it run on Resin:
<!-- xml -->
          <system-property  
javax.xml.parsers.DocumentBuilderFactory="org.apache.xerces.jaxp.Documen 
tBuilderFactoryImpl"/>
          <system-property  
javax.xml.parsers.SAXParserFactory="org.apache.xerces.jaxp.SAXParserFact 
oryImpl"/>
<!--  xslt -->
           <system-property  
javax.xml.transform.TransformerFactory="org.apache.xalan.processor.Trans 
formerFactoryImpl"/>

And <load-on-startup> has been commented out to get setup wizard to  
start.

Full install 6.0.2: Cannot be installed because at some point OpenCMS  
webapp shutdowns during the modules import
Full Install 6.0.0: Otherwise seems to work well but welcome page and  
some example pages don't seem to work. Gives 500 Server Error with  
opencms links in top
Upgrade from 6.0.0 to 6.0.2: Fails during upgrade bit same way as  
with full installation of 6.0.2

Any ideas to make fully working and successful installation?

- Jalmari 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opencms.org/pipermail/opencms-dev/attachments/20051018/08bed281/attachment.html>


More information about the opencms-dev mailing list