[opencms-dev] Installation problem with Resin

Bryan LaPlante blaplante at netwebapps.com
Thu Jun 19 19:31:01 CEST 2003


Installation problem with ResinMay or may not help you but here is something I experienced. 

On a winXP machine running Tomcat I tried to do like the directions suggested and it did not work as well because I was starting tomcat as an NT service and none of the environment variables were being picked up. I had to start Tomcat from the command line and when I did it found my file.encoding variable and worked fine.

I have not played with resin but hopefully that will give you some more thoughts.

Bryan LaPlante
  ----- Original Message ----- 
  From: rasheed 
  To: opencms-dev at opencms.org 
  Sent: Thursday, June 19, 2003 12:10 PM
  Subject: [opencms-dev] Installation problem with Resin


  When I run the opensetup wizard by going to http://localhost:8080/opencms/ocsetup , I get this error .. 

  Error: the encoding of your Java VM is different from the OpenCms encoding! 
  Java VM file encoding:  Cp1252 
  OpenCms encoding:       ISO-8859-1     

  My question is what I need to change the file.encoding scheme of my Java virtual machine. I used resin.conf configuration file of Resin and added the line mentioned below but it did not work. To Run Resin, we use httpd.exe that's why I can't add -Dfile.encoding=ISO-8859-1 while using Java vertual machine. 

  <web-app id='/'> 
          <!-- adds xsl to the search path --> 
          <class-loader> 
            <simple-loader path="$host-root/xsl"/> 
          </class-loader> 
          <character-encoding>ISO-8859-1</character-encoding> 
          <servlet-mapping url-pattern="/servlet/*" servlet-name="invoker"/> 
        </web-app> 
  I am using 
  Resin-3.0.1-beta 
  j2sdk1.4.1_03 
  OpenCMS ver 5.0.0 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opencms.org/pipermail/opencms-dev/attachments/20030619/9a0bd29d/attachment.html>


More information about the opencms-dev mailing list