[opencms-dev] Communication Link Error

Steve steven at livingimpact.com.my
Thu Jun 12 11:33:04 CEST 2003


Hello, 

    Thanks for taking your time to answer my question, I have altered the opencms.properties file parameter timeout and maxage of mysql pool but without any improvement. I am still getting the same message. 

    Can anyone please help. Thanks.

Steven Ho 
steven at livingimpact.com.my
  ----- Original Message ----- 
  From: Brendon Price 
  To: 'opencms-dev at opencms.org' 
  Cc: 'steven at livingimpact.com.my' 
  Sent: Wednesday, June 11, 2003 11:32 AM
  Subject: RE: [opencms-dev] Communication Link Error


  Steve,

  I haven't looked at this much myself, but It looks like it is set with the opencms.properties file,
  From the source code of OpenCMS it says:

  com.opencms.dbpool.CmsPool.java
  /**

  * Test the connection by executing an select statement. This is done

  * only if the statement is defined in opencms.properties. Normally there

  * is no need for this testing - but in difficult environments (like firewalls)

  * you can use it to find out whats going wrong.

  * @param con The connection to test.

  * @return true if the connection could be tested without an SQLException.

  * Returns true if there is no test-statement defined in opencms.properties.

  * Returns false if there was an SQLException by executing the statement.

  */



  The property to use is shown here; but choose your own select query (keep it simple).
  pool.mysql.testQuery=select count(*) from CMS_USERS


  Regards

  Brendon

    -----Original Message-----
    From: Steve [mailto:steven at livingimpact.com.my]
    Sent: Wednesday, 11 June 2003 3:16 p.m.
    To: opencms-dev at opencms.org
    Subject: Re: [opencms-dev] Communication Link Error


    Hi all,

        I already contacted the hosting company and they claim that there is no firewall for the mysql server. Btw how to set connection pool to use "keep alives"? Is the setting done in opencms or mysql server?

    Thanks a lot,
    Steven Ho
      ----- Original Message ----- 
      From: Brendon Price 
      To: 'opencms-dev at opencms.org' 
      Cc: 'steven at livingimpact.com.my' 
      Sent: Wednesday, June 11, 2003 10:28 AM
      Subject: RE: [opencms-dev] Communication Link Error


      Hi Steve,

      Just guessing, but is it possible that your connection to your database is via a firewall that times out your database connections?
      I know we have had similar issues in the past with other applications we have hosted. If the connection pool uses "keep alives" you can avoid this problem. If it is indeed this problem that is actually occurring.

      Regards
      Brendon
        -----Original Message-----
        From: Steve [mailto:steven at livingimpact.com.my]
        Sent: Wednesday, 11 June 2003 2:00 p.m.
        To: opencms-dev at opencms.org
        Subject: [opencms-dev] Communication Link Error


        Hi all,

            I have deployed a website using which occasionally have error mesg that display mysql exception: communication link error. The current workaround I have now is to use a webpage that keep refreshing the website, this way the communication link would not appear. 
            Anyone have experience in this, I have surf the archive b4 and tried updating mysql-J connector to the latest release. But nothing work.

        Thanks in advance,
        Steven Ho

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opencms.org/pipermail/opencms-dev/attachments/20030612/820fb8b6/attachment.html>


More information about the opencms-dev mailing list