[opencms-dev] Could not connect to the database Error-- follow uo

Russell Castagnaro russell at synctank.com
Fri May 16 01:50:01 CEST 2003

Hello All,

Sorry I couldn't follow the existing thread on this, but I just signed
up.  I had the same problem as Yogen Kapadia and noticed in his posting he
is using Cp1252 encoding.  I'm having the same problem as him, and
THAT is the problem, not the database.  I'm not sure what to do as I
put the "defaultContentEncoding=Cp1252" entry into the opencms.properties file because I tried
just about everything else to change the encoding in my VM.  I'm
running on Windows XP (no spam please, lit will be linux on the
server eventually).  I tried to put
set CATALINA_OPTS=-Dfile.encoding=ISO-8859-1
in the startup and catalina batch files, to no avail.  I even put
-Dfile.encoding=ISO-8859-1 on the java invocation lines, but the darn
system wouldn't install!

With this in mind, does anyone have a clue how to fix this?

com.opencms.core.CmsException: 33 Resourcebroker-init error. Detailed error: Database init failed.
root cause was com.opencms.core.CmsException: 33 Resourcebroker-init error. Detailed error: Critical error while loading resourcebroker. 
root cause was com.opencms.core.CmsException: 34 Registry error. Detailed error: couldn't init registry. 
root cause was com.opencms.core.CmsException: 21 XML parsing error. Detailed error: Cannot parse XML file "null". org.xml.sax.SAXParseException: Invalid encoding name "Cp1252".. 

Best regards,
Russell Castagnaro                         mailto:russell at synctank.com
Director of Research & Development
SyncTank Solutions, Inc

More information about the opencms-dev mailing list