[opencms-dev] Problems using xml-templates

Thomas Kraft thomas.kraft at synyx.de
Tue Apr 1 09:53:47 CEST 2003

I tried this but it doesn't worked :(

Then I changed the type of all my xml-templates into "plain". Then the
export worked. ;?
Can anybody tell me why my xml-templates must not from the type
"xml-template" but from "plain" ??
regards, Thomas

>>> Sechmanj at audits.state.ga.us 03/31/03 6:32PM >>>
May want to make sure you've specified the encoding attribute in the xml
declarationfor all of the template files:

<?xml version="1.0" encoding="ISO-8859-1"?>

I ran into this as well...


Joe Sechman

>>> thomas.kraft at synyx.de 03/31/03 11:15AM >>>
Hi there,

i tried to create a page and i get a error i can't explain (OpenCMS
Version 5 RC2):I have a Mastertemplate located in
/system/modules/templates/org.opencms.default/ with a content like this:
<?xml version="1.0"?>
  <elementdef name="contenttemplate">
  <elementdef name="tabletemplate">
    <element name="contenttemplate"/>

The Type of this file is xml-template (Why are the open-cms templates type
"plain" ??)
I have the defined subtemplates (contenttemplate + tabletemplate) located
in the /synyx/templates folder. These are type "xml-template", too.
they look like this:


<?xml version="1.0"?>
<template><![CDATA[ <html-code> ]]>
<element name="tabletemplate"/><![CDATA[<more-html-code>


<?xml version="1.0"?>
<template><![CDATA[ <html-code> ]]>


I created a html file called "index.html" in the /synyx/ folder of my
project using my own mastertemplate as "Template" of this html File.
When I click on this "index.html" file I created, a popup window occurs
displaying my site correctly. With all the html-code of the two templates
"contenttemplate" and "tabletemplate". That's fine. But when I try to
publish this projekt it doesn't work. The OpenCMS tells me the following
"The file /synyx/index.html" doesn't exist - skipping export

Exception com.opencms.core.CmsException: 17 Service not available.
Detailed error: There was an error while parsing XML page file
/synyx/templates/tabletemplate.root cause was
com.opencms.core.CmsException: 20Wrong XML content type.
Detailed error: XML document /synyx/templates/tabletemplate is not of the
expected type. This document is "xmltemplate" but it should be "PAGE"
(OpenCms XML Page File)
Now i ask me: Why is the document type of the wrong type? Why can't I use
XMLTemplates here in the context?
I would be very pleased if you could tell me where my failure is.

Thanks in advance,

Thomas Kraft

"<audits.state.ga.us>" made the following
 annotations on 03/31/2003 11:32:34 AM

This message is intended for the designated recipient only, if this
message was notintended for you, please ignore and delete this message immediately.

More information about the opencms-dev mailing list