[opencms-dev] element cache & multiple bodies -> NullPointerException

O_Faulhaber at push-interactive.de O_Faulhaber at push-interactive.de
Thu Sep 6 14:02:21 CEST 2001


Hi OpenCms-Developers

I need urgent assistance: when i request a page which contains two bodies
(defined in the master template) and the element cache is enabled (in
opencms.properties) then a NullpointerException will be thrown (take look at
stacktrace.txt). The Exception only occures, when the templateselector-tag
is used in the elementdef section.

i am really helpless, what am i doing wrong?

------master template------

<?xml version="1.0"?>
<XMLTEMPLATE>
<TEMPLATE>
<![CDATA[
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
<head>
<title>]]><method name="getTitle"/><![CDATA[</title>
</head>
<BODY>
	]]>
	<ELEMENT name="body"/>
	<ELEMENT name="body2"/>
	<![CDATA[
</BODY>
</html>
]]>
</TEMPLATE>
<ELEMENTDEF name="body2">
	<TEMPLATESELECTOR>body2</TEMPLATESELECTOR>
</ELEMENTDEF>
</XMLTEMPLATE>


--------------------------------------------------------------------
Dipl.-Inform./Medien (FH)       Oliver Faulhaber
Push Interactive GmbH           Fon: +49/202/2427-346
VillaMedia, Viehhofstrasse 125  Fax: +49/202/2427-310
D-42117 Wuppertal               URL: http://www.push-interactive.de/
--------------------------------------------------------------------

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: stacktrace.txt
URL: <http://lists.opencms.org/pipermail/opencms-dev/attachments/20010906/a5feffa0/attachment.txt>


More information about the opencms-dev mailing list